使WordPress运行PHP代码的插件

By | 2010年4月18日

众所周知,WordPress的侧边栏和文章不能够直接运行自定义的php代码,reizhi今天给各位介绍一个插件,它能改变这一现状。

插件名称:Exec-PHP    点我下载

使用方法:上传以后启用即可。 值得注意的是,启用以后在新建文章页面会看到一个大大的提示。只要到“用户》我的配置”关闭“启用可视化编辑器”即可。

另外还需在”设置》拟写“中,关闭”WordPress自动改正xHTML错误“。

在侧边栏使用PHP代码直接添加”文本“小工具然后在其中加入代码即可。

在文章中使用PHP代码请切换到HTML编辑器模式,或者使用第三方编辑器,直接输入代码。不要使用所见即所得编辑模式。

 

插件作者页面:http://bluesome.net/post/2005/08/18/50/

插件的设置很简单,只有一个选项。而另外的则是一些运行信息。

点小图看大图,图来自作者博客。

33 thoughts on “使WordPress运行PHP代码的插件

    1. reizhi 博主

      但是在文章中直接寫入PHP代碼並不能運行
      WP當成文本對待

      回复
    1. reizhi 博主

      当然安全,评论又不会启用PHP,而且能启用的用户也有限制

      回复
  1. 沉睡海洋

    这样也行
    不过我一直在思索用代码实现这个功能的方式
    不过还是收藏一下,至少插件的代码可以参考一下。

    回复
  2. andrew

    哎,这个插件今天我下载了,安装不上啊,说没有标题名称啊,显示不出来,进FTP后台看是有文件的。呵呵,博主评论还允许XHTML标签,好,我试下。
    我的博客:老男孩博客

    回复

发表评论

电子邮件地址不会被公开。 必填项已用*标注